指尖金融网(www.scwzjs.net)分享每日股票行情和全面的金融知识!

MACD面积副图指标 源码 通达信 贴图 无未来

指尖金融网 股票学校 2020-06-18 09:48:10 89
指尖金融网(www.scwzjs.net)提示:您正在查看的是:MACD面积副图指标 源码 通达信 贴图 无未来

分享一个可以直观看到MACD红绿柱面积数值以及黄白线数值的MACD优化指标。

如图:红箭头处MACD力度明显背驰,但指数新高,上动力不足,很直观就可以看出来。

{周放大开关:1为普通模式,0为放大模式}
周期放大:=1;
数显开关:=1;
倍数:=
IF(PERIOD=11,1,{年}
IF(PERIOD=10,4,{季}
IF(PERIOD=9,6, {多日}
IF(PERIOD=8,10,{多分钟}
IF(PERIOD=7,12,{月}
IF(PERIOD=6,5, {周}
IF(PERIOD=5,5, {日}
IF(PERIOD=4,4, {60F}
IF(PERIOD=3,8, {30F}
IF(PERIOD=2,4, {15F}
IF(PERIOD=1,6, {5F}
IF(PERIOD=0,5, {1F}
1))))))))))));
N1:=IF(周期放大,12,12*倍数);
N2:=IF(周期放大,26,26*倍数);
N3:=IF(周期放大,9,9*倍数);
DIFF:EMA(CLOSE,N1) - EMA(CLOSE,N2),COLORWHITE,NODRAW;
DEA:EMA(DIFF,N3),COLORYELLOW,NODRAW;
MACD: (DIFF-DEA)*2,COLORSTICK,NODRAW;
红柱面积:IF(MACD>0,SUM(MACD,BARSLAST(MACD<0)),0),NODRAW,COLORRED;
绿柱面积:ABS(IF(MACD<0,SUM(MACD,BARSLAST(MACD>0)),0)),NODRAW,COLORLIGREEN;
MACD面积:=IF(MACD>0,红柱面积,绿柱面积),NODRAW,COLORFFFF00;
位置:=MAX(HHV(DIFF,100),ABS(LLV(DIFF,100)));
{柱变与交叉临界}
开盘价格:=O,COLORYELLOW,NODRAW;
收盘价格:=C,COLORYELLOW,NODRAW;
最高价格:=H,COLORYELLOW,NODRAW;
最低价格:=L,COLORYELLOW,NODRAW;
振幅:=(H-L)/REF(C,1)*100,COLORYELLOW,NODRAW;
柱变临界:REF((EMA(CLOSE,12)*1134-EMA(CLOSE,26)*910-DEA*702)/224,1),COLORLIMAGENTA,NODRAW;
交叉临界:351/28*
(EMA(REF(DIFF,1),9)-11/13*EMA(REF(C,1),12)+25/27*EMA(REF(C,1),26)),COLORLIMAGENTA,NODRAW;
明日柱变临界: (EMA(CLOSE,12)*1134-EMA(CLOSE,26)*910-DEA*702)/224,COLORLIBLUE,NODRAW;
明日交叉临界:351/28*(EMA(DIFF,9)-11/13*EMA(C,12)+25/27*EMA(C,26)),COLORLIBLUE,NODRAW;
{MACD重建-避免遮挡}{好股票WWW.GOODGUPIAO.COM}
STICKLINE(MACD>0,0,MACD,1,0),COLORRED;
STICKLINE(MACD<0,0,MACD,1,0),COLORGREEN;
STICKLINE(MACD>0 AND MACD<=REF(MACD,1),0,MACD,1,0),COLORYELLOW;
STICKLINE(MACD<0 AND MACD>=REF(MACD,1),0,MACD,1,0),COLORWHITE;
NOTEXTDIFF:EMA(CLOSE,N1) - EMA(CLOSE,N2),COLORWHITE;
NOTEXTDEA:EMA(DIFF,N3),COLORYELLOW;
{数显开关:1为打开,0为关闭}
DRAWNUMBER(数显开关=1 AND LONGCROSS(DEA,DIFF,3),位置*0.8,REF(红柱面积,1)),COLORRED;
DRAWNUMBER(数显开关=1 AND LONGCROSS(DIFF,DEA,3),0-位置*0.5,REF(绿柱面积,1)),COLORGREEN;
NOTEXTLMH: DRAWNUMBER(数显开关=1 AND ISLASTBAR AND MACD>0,位置*0.8,红柱面积),COLORRED;
NOTEXTLML: DRAWNUMBER(数显开关=1 AND ISLASTBAR AND MACD<0,0-位置*0.5,绿柱面积),COLORGREEN;



指尖金融网股票学校直达:http://scwzjs.net/xuexiao/gupiaoxuexiao/

指尖金融网基金学校直达:http://scwzjs.net/xuexiao/jijinxuexiao/

指尖金融网外汇学校直达:http://scwzjs.net/xuexiao/waihuixuexiao/

指尖金融网理财学校直达:http://scwzjs.net/xuexiao/licaixuexiao/

指尖金融网保险学校直达:http://scwzjs.net/xuexiao/baoxianxuexiao/

分享:

本文来自投稿,不代表本人立场,如若转载,请注明出处:http://scwzjs.net/xuexiao/gupiaoxuexiao/171075.html

郑重声明:指尖金融网发布此信息的目的在于传播更多信息,与本站立场无关。指尖金融网不保证该信息(包含但不限于文字、视频、音频、数据及图表)全部或者部分内容的准确性、真实性、完整性、有效性、及时性、原创性等。相关信息并未经过本网站证实,不对您构成任何投资建议,据此操作,风险自担。

  MACD面积副图指标 源码 通达信 贴图 无未来   通达信公式下载   股票公式  

(89)
打赏 微信扫一扫
« 上一篇 2020年06月18日 09:41:36
下一篇 » 2020年06月18日 09:48:17

相关文章

MACD面积副图指标 源码 通达信 贴图 无未来_相关内容