指尖金融网(www.scwzjs.net)分享每日股票行情和全面的金融知识!

相对空间位置主图指标 通达信 源码 附图

指尖金融网 股票学校 2020-06-19 08:18:34 100
指尖金融网(www.scwzjs.net)提示:您正在查看的是:相对空间位置主图指标 通达信 源码 附图

天顶线:CONST(COST(99.999)),LINETHICK3;
中轴线:CONST(COST(50)),LINETHICK3;
地底线:CONST(COST(0.001)),LINETHICK3; HHHH:=H=CONST(HHV(H,0));
LLLL:=L=CONST(LLV(L,0));
PP:=BARSLAST(HHHH)+1;
TT:=BARSLAST(LLLL)+1;
STICKLINE((PP=1),HHV(H,0),LLV(L,0),3,0),COLORBROWN;
STICKLINE((TT=1),HHV(H,0),LLV(L,0),3,0),COLORGRAY; 获利盘001%:=REFDATE(CONST(COST(0.001)),DATE),LINETHICK6,COLORYELLOW;
获利盘01%:=REFDATE(CONST(COST(0.01)),DATE),LINETHICK6,COLORYELLOW;
DRAWBAND(获利盘001%,RGB(250,150,250),获利盘01%,RGB(250,150,250)); 获利盘49%:=REFDATE(CONST(COST(49)),DATE),LINETHICK6,COLORYELLOW;
获利盘51%:=REFDATE(CONST(COST(51)),DATE),LINETHICK6,COLORYELLOW;
DRAWBAND(获利盘49%,RGB(250,150,250),获利盘51%,RGB(250,150,250)); 获利盘99.9%:=REFDATE(CONST(COST(99.9)),DATE),LINETHICK6,COLORYELLOW;
获利盘99.99%:=REFDATE(CONST(COST(99.999)),DATE),LINETHICK6,COLORYELLOW;
DRAWBAND(获利盘99.9%,RGB(250,150,250),获利盘99.99%,RGB(250,150,250));高点:=REFDATE(CONST(REF(HHV(H,0),0)),DATE),DOTLINE;
低点:=REFDATE(CONST(REF(LLV(L,0),0)),DATE),DOTLINE; GD:=CONST(FINDHIGH(H,0,高点*10,1));
DD:=CONST(FINDLOW(L,0,低点*10,1));
GT:=CONST(BARSLAST(GD=H))+1;
DT:=CONST(BARSLAST(DD=L))+1;
SH:=CONST(IF(GT=1,H,REF(H,GT-1)));
SL:=CONST(IF(DT=1,L,REF(L,DT-1)));
CC:=IF(DT>GT,DT,GT);
CD:=INTPART(CC-(DT+GT)/2);
CG:=IF(高点>CD,CD/2,高点);
下跌:BARSLAST(GD=H),COLORBROWN,NODRAW;
跌幅度:IF(CURRBARSCOUNT<=GT,C/SH*100-100,DRAWNULL),NODRAW,COLORRED;
均价:=IF(CURRBARSCOUNT<=GT,SUM(AMOUNT,GT)/SUM(V,GT)/100,DRAWNULL),NODRAW,COLORLIGRAY;
下跌换手:IF(CURRBARSCOUNT<=GT,SUM(HSL.HSL,GT),DRAWNULL),COLORGREEN,NODRAW; 上周期:IF(CURRBARSCOUNT<=DT,BARSLAST(DD=L),DRAWNULL),COLORBROWN,NODRAW;
涨幅度:IF(CURRBARSCOUNT<=DT,C/SL*100-100,DRAWNULL),NODRAW,COLORRED;
上涨均价:=IF(CURRBARSCOUNT<=DT,SUM(AMOUNT,DT)/SUM(V,DT)/100,DRAWNULL),NODRAW,COLORLIGRAY;
上涨换手:IF(CURRBARSCOUNT<=DT,SUM(HSL.HSL,DT),DRAWNULL),COLORMAGENTA,NODRAW;星期:=VARCAT(VARCAT('(',IF(WEEKDAY=1,'一',IF(WEEKDAY=2,'二',IF(WEEKDAY=3,'三',IF(WEEKDAY=4,'四',IF(WEEKDAY=5,'五','')))))),')');
日期:=VARCAT('-',VARCAT(VARCAT(VARCAT(VARCAT(VARCAT(VARCAT(VAR2STR(YEAR,0),'年'),VAR2STR(MONTH,0)),'月'),VAR2STR(DAY,0)),'日'),星期)); {幅度尺}
STICKLINE(CURRBARSCOUNT=DT,SL*20,SL,0,-1),COLORRED;
STICKLINE(CURRBARSCOUNT=GT,SH,SH-SH*0.9,0,-1),COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=DT ,(SL+SL*1.2)/2,日期),COLORMAGENTA;
DRAWTEXT(CURRBARSCOUNT=GT ,GD*0.97,日期),COLORMAGENTA;{竖线表示统计起点位置} 上限:=CONST(HHV(H,0));
下限:=CONST(LLV(L,0));
STICKLINE(CURRBARSCOUNT=DT,上限,下限,1,0),COLORMAGENTA;
STICKLINE(CURRBARSCOUNT=GT,上限,下限,1,0),COLORLIGRAY; NN:=5;
LL:=REF(L,1);
HH:=REF(H,1);
SQK:=L>HH;
XQK:=H<LL;
向上跳空:IF(SQK=1,L-HH,DRAWNULL),COLORMAGENTA,NODRAW;
向下跳空:IF(XQK=1,H-LL,DRAWNULL),COLORBROWN,NODRAW;
QK:=IF(L>REF(H,1),L-REF(H,1),IF(H<REF(L,1),REF(L,1)-H,DRAWNULL));
DRAWNUMBER(L>REF(H,1),L,QK);
DRAWNUMBER(H<REF(L,1),H,QK); STICKLINE(SQK,L,HH,4*NN,1),COLORMAGENTA;
STICKLINE(XQK,H,LL,4*NN,2),COLORBROWN;
DRAWTEXT(SQK,L*0.96,' 上跳'),COLORMAGENTA;
DRAWTEXT(XQK,H*1.04,' 下跳'),COLORBROWN;
{画K线}
DRAWKLINE(HIGH,OPEN,LOW,CLOSE);
{拉升起点:=REFDATE(CONST(REF(LLV(L,0),0)),DATE)*1.0,DOTLINE;}
拉升起点:=REFDATE(CONST(COST(0.001)),DATE)*1.00,DOTLINE; 拉升10%:=拉升起点*1.1,DOTLINE;
拉升20%:=拉升10%*1.1,DOTLINE;
拉升30%:=拉升20%*1.1,DOTLINE;
拉升40%:=拉升30%*1.1,DOTLINE;
拉升50%:=拉升40%*1.1,DOTLINE;
拉升60%:=拉升50%*1.1,DOTLINE;
拉升70%:=拉升60%*1.1,DOTLINE;
拉升80%:=拉升70%*1.1,DOTLINE;
拉升90%:=拉升80%*1.1,DOTLINE;
拉升100%:=拉升90%*1.1,DOTLINE;
拉升110%:=拉升100%*1.1,DOTLINE;
拉升120%:=拉升110%*1.1,DOTLINE;
拉升130%:=拉升120%*1.1,DOTLINE;
拉升140%:=拉升130%*1.1,DOTLINE;
拉升150%:=拉升140%*1.1,DOTLINE;
拉升160%:=拉升150%*1.1,DOTLINE;
拉升170%:=拉升160%*1.1,DOTLINE;
拉升180%:=拉升170%*1.1,DOTLINE;
拉升190%:=拉升180%*1.1,DOTLINE;
拉升200%:=拉升190%*1.1,DOTLINE;
拉升210%:=拉升200%*1.1,DOTLINE;
拉升220%:=拉升210%*1.1,DOTLINE;
拉升230%:=拉升220%*1.1,DOTLINE;
拉升240%:=拉升230%*1.1,DOTLINE;
拉升250%:=拉升240%*1.1,DOTLINE;
拉升260%:=拉升250%*1.1,DOTLINE;
DRAWTEXT(CURRBARSCOUNT=DT,拉升起点,'拉升起点'),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=DT,拉升10%,'拉升10%'),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=DT,拉升20%,'拉升20%'),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=DT,拉升30%,'拉升30%'),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=DT,拉升40%,'拉升40%'),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=DT,拉升50%,'拉升50%'),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=DT,拉升60%,'拉升60%'),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=DT,拉升70%,'拉升70%'),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=DT,拉升80%,'拉升80%'),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=DT,拉升90%,'拉升90%'),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=DT,拉升100%,'拉升100%'),COLORYELLOW; DRAWTEXT(CURRBARSCOUNT=DT,拉升110%,'拉升110%'),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=DT,拉升120%,'拉升120%'),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=DT,拉升130%,'拉升130%'),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=DT,拉升140%,'拉升140%'),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=DT,拉升150%,'拉升150%'),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=DT,拉升160%,'拉升160%'),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=DT,拉升170%,'拉升170%'),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=DT,拉升180%,'拉升180%'),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=DT,拉升190%,'拉升190%'),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=DT,拉升200%,'拉升200%'),COLORYELLOW; DRAWTEXT(CURRBARSCOUNT=DT,拉升210%,'拉升210%'),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=DT,拉升220%,'拉升220%'),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=DT,拉升230%,'拉升230%'),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=DT,拉升240%,'拉升240%'),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=DT,拉升250%,'拉升250%'),COLORYELLOW;{回踩起点:=REFDATE(CONST(REF(HHV(H,0),0)),DATE)*1.0,DOTLINE;}
回踩起点:=REFDATE(CONST(COST(99.999)),DATE)*1.0,DOTLINE; 回踩10%:=回踩起点*0.90,DOTLINE;
回踩20%:=回踩10%*0.90,DOTLINE;
回踩30%:=回踩20%*0.90,DOTLINE;
回踩40%:=回踩30%*0.90,DOTLINE;
回踩50%:=回踩40%*0.90,DOTLINE;
回踩60%:=回踩50%*0.90,DOTLINE;
回踩70%:=回踩60%*0.90,DOTLINE;
回踩80%:=回踩70%*0.90,DOTLINE;
回踩90%:=回踩80%*0.90,DOTLINE;
回踩100%:=回踩90%*0.90,DOTLINE; 回踩110%:=回踩100%*0.90,DOTLINE;
回踩120%:=回踩110%*0.90,DOTLINE;
回踩130%:=回踩120%*0.90,DOTLINE;
回踩140%:=回踩130%*0.90,DOTLINE;
回踩150%:=回踩140%*0.90,DOTLINE;
回踩160%:=回踩150%*0.90,DOTLINE;
回踩170%:=回踩160%*0.90,DOTLINE;
回踩180%:=回踩170%*0.90,DOTLINE;
回踩190%:=回踩180%*0.90,DOTLINE;
回踩200%:=回踩190%*0.90,DOTLINE;
回踩210%:=回踩200%*0.90,DOTLINE;
回踩220%:=回踩210%*0.90,DOTLINE;
回踩230%:=回踩220%*0.90,DOTLINE;
回踩240%:=回踩230%*0.90,DOTLINE;
回踩250%:=回踩240%*0.90,DOTLINE;
回踩260%:=回踩250%*0.90,DOTLINE;
DRAWTEXT(CURRBARSCOUNT=GT,回踩起点,'回踩起点'),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=GT,回踩10%,'回踩10%'),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=GT,回踩20%,'回踩20%'),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=GT,回踩30%,'回踩30%'),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=GT,回踩40%,'回踩40%'),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=GT,回踩50%,'回踩50%'),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=GT,回踩60%,'回踩60%'),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=GT,回踩70%,'回踩70%'),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=GT,回踩80%,'回踩80%'),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=GT,回踩90%,'回踩90%'),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=GT,回踩100%,'回踩100%'),COLORYELLOW; DRAWTEXT(CURRBARSCOUNT=GT,回踩110%,'回踩110%'),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=GT,回踩120%,'回踩120%'),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=GT,回踩130%,'回踩130%'),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=GT,回踩140%,'回踩140%'),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=GT,回踩150%,'回踩150%'),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=GT,回踩160%,'回踩160%'),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=GT,回踩170%,'回踩170%'),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=GT,回踩180%,'回踩180%'),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=GT,回踩190%,'回踩190%'),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=GT,回踩200%,'回踩200%'),COLORYELLOW; DRAWTEXT(CURRBARSCOUNT=GT,回踩210%,'回踩210%'),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=GT,回踩220%,'回踩220%'),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=GT,回踩230%,'回踩230%'),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=GT,回踩240%,'回踩240%'),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=GT,回踩250%,'回踩250%'),COLORYELLOW;
DRAWTEXT(YEAR!=REF(YEAR,1),HIGH+0.3,VARCAT(VAR2STR(YEAR,0),' 年 ')),COLORWHITE;
STICKLINE(YEAR!=REF(YEAR,1)=1,CONST(HHV(H,0)),CONST(LLV(L,0)),0,-1),COLORWHITE; DRAWTEXT(MONTH!=REF(MONTH,1),LOW-0.2,VARCAT(VAR2STR(MONTH,0),' 月 ')),COLORWHITE;
STICKLINE(MONTH!=REF(MONTH,1)=1,CONST(HHV(H,0)),CONST(LLV(L,0)),0,-1),COLORWHITE; DRAWTEXT(WEEKOFYEAR!=REF(WEEKOFYEAR,1),LOW,VARCAT(VAR2STR(WEEKOFYEAR,0),' 周 ')),COLORWHITE;
STICKLINE(WEEKOFYEAR!=REF(WEEKOFYEAR,1)=1,CONST(HHV(H,0)),CONST(LLV(L,0)),0,-1),COLORWHITE; DRAWTEXT(DAY!=REF(DAY,1),LOW-0.2,VARCAT(VAR2STR(DAY,0),' 日 ')),COLORWHITE;
STICKLINE(DAY!=REF(DAY,1)=1,CONST(HHV(H,0)),CONST(LLV(L,0)),0,-1),COLORWHITE; {画K线}
DRAWKLINE(HIGH,OPEN,LOW,CLOSE);


指尖金融网股票学校直达:http://scwzjs.net/xuexiao/gupiaoxuexiao/

指尖金融网基金学校直达:http://scwzjs.net/xuexiao/jijinxuexiao/

指尖金融网外汇学校直达:http://scwzjs.net/xuexiao/waihuixuexiao/

指尖金融网理财学校直达:http://scwzjs.net/xuexiao/licaixuexiao/

指尖金融网保险学校直达:http://scwzjs.net/xuexiao/baoxianxuexiao/

分享:

本文来自投稿,不代表本人立场,如若转载,请注明出处:http://scwzjs.net/xuexiao/gupiaoxuexiao/172538.html

郑重声明:指尖金融网发布此信息的目的在于传播更多信息,与本站立场无关。指尖金融网不保证该信息(包含但不限于文字、视频、音频、数据及图表)全部或者部分内容的准确性、真实性、完整性、有效性、及时性、原创性等。相关信息并未经过本网站证实,不对您构成任何投资建议,据此操作,风险自担。

  相对空间位置主图指标 通达信 源码 附图   通达信公式下载   股票公式  

(100)
打赏 微信扫一扫
« 上一篇 2020年06月19日 08:18:33
下一篇 » 2020年06月19日 08:18:43

相关文章

相对空间位置主图指标 通达信 源码 附图_相关内容